Batch finalization paused
Incident Report for Scroll
Postmortem

A bug was introduced in the recent code refactor in the zkevm circuit. The bus-mapping didn’t handle the return data correctly for error cases. A fix was patched to the zkevm-circuit repo in this PR https://github.com/scroll-tech/zkevm-circuits/pull/813.

This incident caused a pause in the finalization and withdrawal on L1.

Posted Aug 30, 2023 - 02:31 UTC

Resolved
This incident has been resolved. The batch finalization and user withdrawals are resumed.
Posted Aug 24, 2023 - 10:31 UTC
Monitoring
We've indentified the problem and deployed a fix. Currently the proving and finalization can continue, we will keep monitoring the finalization progress. Note that because the number of upgraded provers are limited, the computing power in the network is less than usual, and the finalization will make slower progress than usual.
Posted Aug 24, 2023 - 03:41 UTC
Investigating
We encounter proving errors again. Currently batch finalization is paused. Withdrawals in block 148,600 and higher are on hold.
Posted Aug 23, 2023 - 15:13 UTC
Identified
We're upgrading our coordinator and are experiencing proving paused. Withdrawals in block 148,600 and higher are on hold.
Posted Aug 23, 2023 - 13:07 UTC
This incident affected: Scroll Sepolia (Bridge, Prover Network).