Batch finalization error
Incident Report for Scroll
Postmortem

Our chain monitor recently detected a discrepancy in the ETH balance between Scroll’s L1 and L2 messengers. In our commitment to upholding the highest security standards, we promptly halted the sequencer to thoroughly investigate this matter. After a careful review, we can confirm that this was a false alarm stemming from a bug in the chain monitor itself. We have rectified the issue and the sequence has been successfully restarted, ensuring the security and stability of our platform. Your safety is our top priority, and we appreciate your understanding as we remain extra cautious and security-first in all our operations.

Posted Oct 24, 2023 - 13:54 UTC

Resolved
This incident has been resolved.
Posted Oct 22, 2023 - 23:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2023 - 22:54 UTC
Investigating
Our batch finalization has encountered an error. Currently, withdrawals after block 221642 are on hold. We also paused the network to look into the entire issue.
Posted Oct 22, 2023 - 21:21 UTC
This incident affected: Scroll (Sequencer (execution node), Sequencer (rollup node), Bridge).