Mainnet Sequencer on Hold
Incident Report for Scroll
Postmortem

Earlier today the Scroll engineering team deployed a new version of the Scroll sequencer.

At approximately 16:40 UTC, an unanticipated edge case related to the circuit capacity calculation prevented the sequencer from producing new blocks.

As a fix, we rolled back to a previous version of the sequencer and reorged the affected blocks (from block 9025450 to block 9025427). After this, the sequencer resumed normal operation, and Scroll batches are now being committed and finalized normally.

Posted Sep 05, 2024 - 19:16 UTC

Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 19:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 17:05 UTC
Investigating
We are currently investigating this issue.
Posted Sep 05, 2024 - 16:45 UTC
This incident affected: Scroll (Sequencer (execution node), Public RPC Endpoint, Blockchain Explorer).