Batch Finalization Delayed

Incident Report for Scroll

Resolved

The batch finalization have caught up. This incident has been resolved.
Posted Mar 28, 2025 - 01:24 UTC

Identified

due to increased activity on Scroll batch finalization are lagging behind. The system is fully operational but withdrawals are expected to be delayed. The team is working on adding additional proving capacity.
Posted Mar 27, 2025 - 00:45 UTC
This incident affected: Scroll Sepolia (Sequencer (rollup node), Prover Network).