Finalization Delayed Due to Increased Demand
Incident Report for Scroll
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 18:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 15, 2024 - 18:45 UTC
Identified
Due to increased demand on the Scroll mainnet, batch proving and finalization are currently delayed. We are working on increasing our proving capacity to match the demand. Users withdrawing to Ethereum should expect increased latency.
Posted Jul 15, 2024 - 10:09 UTC
This incident affected: Scroll (Bridge, Prover Network).