Finalization on hold
Incident Report for Scroll
Resolved
This incident has been resolved.
Posted Jul 06, 2024 - 05:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 05, 2024 - 19:06 UTC
Update
To mitigate the issue, we will revert all pending (unfinalized) batches starting from batch index 275119. L2 transacions and blocks will not be affected (there will be no L2 chain reorg). However, applications indexing on-chain batch data should make sure they can handle both CommitBatch and RevertBatch events from the ScrollChain contract.
Posted Jul 05, 2024 - 17:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 16:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 05, 2024 - 16:22 UTC
Investigating
Batch finalization is currently on hold. We are investigating the root cause. Withdrawals are expected to be delayed.
Posted Jul 05, 2024 - 15:21 UTC
This incident affected: Scroll (Sequencer (rollup node), Bridge, Prover Network).