L2 Blockscout Unavailable
Incident Report for Scroll
Resolved
This incident has been resolved.
Posted Sep 21, 2023 - 20:18 UTC
Investigating
Due to increased user activity, https://sepolia-blockscout.scroll.io is down. Other blockchain explorers remain available. We're investigating the issue.
Posted Sep 21, 2023 - 08:12 UTC
This incident affected: Scroll Sepolia (Blockchain Explorer).